Welcome, Guest
Submit ComicRack bugs to get them squashed

TOPIC: Debug flags not working as expected

Debug flags not working as expected 11 years 1 month ago #223

  • wadegiles
  • wadegiles's Avatar
  • Offline
  • Gold Boarder
  • Posts: 248
  • Thank you received: 3
  • Karma: 20
Without using any flags, I can edit a script and see the results immediately without restarting ComicRack. With the debugging flags set on a shortcut, scripts are not reloaded on the fly.
The administrator has disabled public write access.

Re:Debug flags not working as expected 11 years 1 month ago #224

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 676
  • Karma: 184
i look into it, maybe i reversed the flag :)

But the output window should work...

at least when using the correct flag -ssc :)
Last Edit: 11 years 1 month ago by cYo.
The administrator has disabled public write access.

Re:Debug flags not working as expected 11 years 1 month ago #225

  • wadegiles
  • wadegiles's Avatar
  • Offline
  • Gold Boarder
  • Posts: 248
  • Thank you received: 3
  • Karma: 20
I'm gonna try turning on only the -dso flag. I'm assuming this stands for debug standard output or something like that.
The administrator has disabled public write access.

Re:Debug flags not working as expected 11 years 1 month ago #226

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 676
  • Karma: 184
-dso is Disable Script Optimization

but as you correctly found out, this is broken and actually is always disabled :)
So in the current ComicRack build you turn optimization on with this flag...

-ssc is Show Script Console

With this you get a look at all your script output (good for debugging messages).
The administrator has disabled public write access.
Time to create page: 0.144 seconds

Who's Online

We have 127 guests and one member online