Welcome, Guest
Submit ComicRack bugs to get them squashed

TOPIC: CR .158-172: Comic Rack crashes & the Red X... (Loading new books/pages?)

Re: CR .158/168: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 8 months ago #30020

  • Casublett
  • Casublett's Avatar
  • Offline
  • Gold Boarder
  • Posts: 168
  • Thank you received: 19
  • Karma: 3
Update: 168 still exhibits this behavior, but I haven't had the time to try the different archives engines. When I get around to it, it any of them change the problem, I'll update this thread.
Last Edit: 4 years 5 months ago by Casublett.
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 8 months ago #30022

  • Oberon1464
  • Oberon1464's Avatar
  • Offline
  • Senior Boarder
  • Posts: 73
  • Thank you received: 4
  • Karma: 1
I also (still) experience sporadic crashes and a number of red X's in addition to "blank" pages in the reader (see screenshot 1).
When I scroll through the pages some will appear of will appear and vanish again.

At first I was reluctant to mention this, was attributing it to my hardware.
My PC hasn't got the most recent hardware, but Windows 7 gives it a 5.7-7.4 performance rating.
But since there are still users getting red X's I thought to give it a go of mentioning it...

Windows 7 - 32-bit
AMD Phenom II X2 550 3.10 GHz processor
4 GB RAM

If anyone has any ideas...
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 8 months ago #30023

  • Oberon1464
  • Oberon1464's Avatar
  • Offline
  • Senior Boarder
  • Posts: 73
  • Thank you received: 4
  • Karma: 1
hmm.. that's odd I seem not to be able to add an attachment..

The "blank" pages in the reader I'm talking about are just the outline of a pages...
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30161

  • Casublett
  • Casublett's Avatar
  • Offline
  • Gold Boarder
  • Posts: 168
  • Thank you received: 19
  • Karma: 3
Something new to add to this weird and rare bug that only a few people have reported:

I've noticed that If I first let the CV scraper display the cover and then "skip" to not actually scrape, it seems to "grease" the file and allow CR to open it "again" without any issues.

I've been doing this for a few days and it hasn't failed me yet. While it still happens in CR proper, as long as I "grease" the archive with CV scraper to display the cover, all is well.

By no means does this fix the bug, and it's a time consuming step, at least for those affected, it might alleviate the issue somewhat.

The giant red X still happens tho.
Last Edit: 4 years 7 months ago by Casublett.
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30302

  • T3KN0Gh057
  • T3KN0Gh057's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 407
  • Thank you received: 114
  • Karma: 27
Wasn't running into crashes, but was getting big Xes on a lot of comics in lots of locations

These are the two settings i changed in the ComicRack.ini file
UseNativeCbz = true
DisableAutoTuneSystem = false


So far so good, but it usually takes an hour or so for the problem to surface, maybe I've just delayed it, if i run into trouble again I'll let you know.

Edit: Yeah well it didn't fix it it too about 3 hours to start but now it's doing it again.

Just cause I'm wondering, anyone else that has this problem, are you using a ATI GPU? Because when i run comicrack on my desktop (which has the same specs as my laptop except a nVidia GPU) I don't get this problem
Last Edit: 4 years 7 months ago by T3KN0Gh057.
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30320

  • T3KN0Gh057
  • T3KN0Gh057's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 407
  • Thank you received: 114
  • Karma: 27
Okay.

I've got the problem (of the red Xes) licked now....

in Preferences/behaviour/Browser: turned off "Selected thumbnails have a dog-ear", and "New loaded thumbnails slowly fade in".

in Preferences/Reader/Display: turned off Anamorphic scaling.


in Preferences/Advance/Cache An Memory Usage: expanded disc caches for all to 2048MB, maxed out memory cache and expanded Max Memory Usage to 512 (1/8 of my total system Memory)

to test it i've selected my main Library folder and ungrouped & unstacked all my comics so that all 26,536 of my comics were visible in the list then zoomed out as far as i could to see the covers and scrolled til all comic thumbnails were loaded. not a single Red X. Went through and select comics at random, in the preview toolbar the images loaded just fine for every one i tested (as well as in the info dialog).

not sure which of those settings fixed it, but the problem seems to be gone.
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30321

  • Casublett
  • Casublett's Avatar
  • Offline
  • Gold Boarder
  • Posts: 168
  • Thank you received: 19
  • Karma: 3
Yeah, I use an ATI myself. Maybe this problem is for ATI users?

Thanks for the setting suggestions for the Red X, I'll try em later and report back.

The crashing is of greater concern for me, but having the red X fixed would be nice too :)
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30324

  • T3KN0Gh057
  • T3KN0Gh057's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 407
  • Thank you received: 114
  • Karma: 27
well after restarting comicrack i have red Xes reappearing again. but a WHOLE LOT LESS. (P.S. I also turned off openGL and changed to GdiPlusHQ for processing thumbnails in ComicRack.ini)
Last Edit: 4 years 7 months ago by T3KN0Gh057.
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30736

  • mal
  • mal's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 19
  • Thank you received: 2
  • Karma: -1
Is this now fixed ? The problem was so bad for me that I went back to 157, and it is rock solid. I would love to go to the latest version, but only if it won't crash. One thing I did notice is that the crashing occurred way more frequently if I was opening comics from within smartlists.
The administrator has disabled public write access.

Re: CR .158 to .162: Comic Rack crashes & the Red X... (Loading new books/pages?) 4 years 7 months ago #30738

  • Casublett
  • Casublett's Avatar
  • Offline
  • Gold Boarder
  • Posts: 168
  • Thank you received: 19
  • Karma: 3
Sad to say, no.

It seems that only a handful of users have this particular issue. As such, we haven't been able to provide much in the way of meaningful information, let alone reliably find what actually triggers the error.

While it doesn't fix it, if you "grease" the file first by opening it in the CV scraper without actually scraping (click skip) it, the issue becomes negligible.

I have gone a full day or two this way without triggering the issue. Just don't forget to do this, as it triggers very quickly if you forgetfully skip this step after "greasing" the files for any period of time.
The administrator has disabled public write access.
Time to create page: 0.195 seconds

Who's Online

We have 190 guests and one member online