Welcome, Guest
Submit ComicRack bugs to get them squashed

TOPIC: Broken software sharpening

Broken software sharpening 2 years 9 months ago #41577

I finally figured out why the image kept getting so sharp but UGLY a second or so after each page transition: The problem only occurs when "Software Filters" is enabled in the options. Since this is default, I assume that everyone sees this. The bug seems to be an incorrect sharpening that actually significantly reduces legibility. It seems to take precedence over the hardware sharpening, so it appears after the hardware version has already displayed.

Original:
'
Hardware-only:

Software-only:

Both:


The problem is even more noticeable on diagonal lines, which become aliased:


vs.


Please fix this sharpening bug. Please also make it pre-render while reading the previous page, so the alternate version doesn't suddenly pop in a full second after page transition. Please finally make the sharpening a radio button with a more descriptive text, so everyone isn't stressing both the gpu and cpu when only one should be active at a time.
Last Edit: 2 years 9 months ago by silverbacknet.
The administrator has disabled public write access.

Broken software sharpening 2 years 9 months ago #41587

  • Shinrai
  • Shinrai's Avatar
  • Offline
  • Platinum Boarder
  • With great power comes great W/T.
  • Posts: 885
  • Thank you received: 81
  • Karma: 33
I don't see this behavior; maybe hardware specific? What are you running on?
The administrator has disabled public write access.

Broken software sharpening 2 years 9 months ago #41589

Shinrai wrote:
I don't see this behavior; maybe hardware specific? What are you running on?
Windows 8.1 laptop w/ Haswell i7, HD 4600 and nVidia 755M. Latest drivers for both. DPI scaled to 125%. I'll test and report back from work tomorrow, where I have a few other systems.
The administrator has disabled public write access.

Broken software sharpening 2 years 7 months ago #41983

  • Sergei
  • Sergei's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
I have exactly same problem.

Running Windows 8.1 on Asus G710JT, 17' screen with 1920x1080 resolution (Full HD).
Got Compatibility Mode (scaling) disabled for ComickRack.

And yes, switching from Software to Hardware filters solves the issue for me. It is worth noting that there are mutiple ways the problem manifests itself:

1. Some comics seems to be completely unaffected.
2. Some only exhibit slight distortions when scrolled to a certain position. Scrolling further down fixes the image.
3. And some become broken only after I scroll to the bottom of the page. Thease are affected most (please check the image below).

I supposed it has something to do with my screen’s high DPI…

(Sorry, I'll post the screenshots separately, can't embed both into this post for some reason).
Last Edit: 2 years 7 months ago by Sergei.
The administrator has disabled public write access.

Broken software sharpening 2 years 7 months ago #41984

  • Sergei
  • Sergei's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
The broken image (with software filters enabled):

The administrator has disabled public write access.

Broken software sharpening 2 years 7 months ago #41985

  • Sergei
  • Sergei's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Sorry, can't embed the normal version of the screenshot. :) I keep attaching it, and my post keeps appearing without it. I hope the broken version above will be enough.
Last Edit: 2 years 7 months ago by Sergei.
The administrator has disabled public write access.
Time to create page: 0.213 seconds

Who's Online

We have 247 guests and 8 members online