Sunday November 23 , 2014
Text Size
   
Welcome, Guest
Username: Password: Remember me
News and Announcements

TOPIC: Comic Vine Scraper 1.0.33 - 1.0.38

Re: Comic Vine Scraper 1.0.33 - 1.0.37 3 years 8 months ago #12588

  • cbanack
  • cbanack's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1178
  • Thank you received: 337
  • Karma: 139
Someone always says that... :)

I actually go out of my way to avoid adding settings and preferences, because I think they make software harder to use--some people like to play around with all sorts of configurations, but most people just want things to work, and lots of extra choices just leads to more headaches.

Actually, I think the biggest problem with most open-source software projects is that they attempt to solve every design question or disagreement by adding a preference or an option--its the easiest way to make everyone happy in the short run, but it ultimately makes software get bloated and confusing, not to mention unwelcoming to new users.

Joel Spolsky writes about this problem quite nicely:

www.joelonsoftware.com/items/2006/11/21.html

Or as Einstein once said: "Any fool can make things bigger, more complex, and more violent. It takes a touch of genius-and a lot of courage-to move in the opposite direction."
Comic Vine Scraper: latest version here, bugs and suggestions here.
The topic has been locked.

Re: Comic Vine Scraper 1.0.33 - 1.0.37 3 years 7 months ago #13227

  • 600WPMPO
  • 600WPMPO's Avatar
  • OFFLINE
  • Moderator
  • Posts: 3717
  • Thank you received: 480
  • Karma: 207
After scraping comic(s), the info is not being saved, sometimes completely and sometimes partially.

After scraping:

4-11-2011 10-43-33 PM_2011-04-13.jpg


After restarting:

4-11-2011 10-41-55 PM_2011-04-13.jpg

dmsimms wrote:
Okay, so for the past few months, I've noticed that when I scrape a comic (using comic vine scraper), then later exit ComicRack, when I go back into it, the comic info that was there is gone! This keeps happening with all the newer titles I've added to my library.

I also get these errors:

Upon clicking the CVS button for the first time:

4-13-2011 9-40-05 PM.jpg


Then upon clicking the second time:

4-13-2011 9-40-11 PM.jpg


On restarting ComicRack, the errors usually disappear..
Now Playing: The ComicRack Manual (Online)

See my new comics & gadgets on: Tumblr!
Last Edit: 3 years 7 months ago by 600WPMPO.
The topic has been locked.

Re: Comic Vine Scraper 1.0.33 - 1.0.37 3 years 7 months ago #13241

  • cbanack
  • cbanack's Avatar
  • OFFLINE
  • Platinum Boarder
  • Posts: 1178
  • Thank you received: 337
  • Karma: 139
600WPMPO wrote:
After scraping comic(s), the info is not being saved, sometimes completely and sometimes partially.
I'll address this over in this thread:

comicrack.cyolito.com/forum/10-bugs/1313...er-comic-vine-scrape

I also get these errors:

Upon clicking the CVS button for the first time:

4-13-2011 9-40-05 PM.jpg


Then upon clicking the second time:

4-13-2011 9-40-11 PM.jpg


On restarting ComicRack, the errors usually disappear..

Hmm... are these relatively new errors, or have they been happening for a while? The last CVS release was about 2 months ago, so if this problem only started happening in the last week or two, it's more likely a problem with ComicRack, or with the ComicVine website.

Do you know of any steps that might get this to happen reliably, so I can reproduce it? One idea might be that the problem only happens when you run some other script before you run CVS? Sometimes if a script shuts down improperly (or borrows some CVS code without renaming the modules) it can "pollute" the scripting environment for other scripts.
Comic Vine Scraper: latest version here, bugs and suggestions here.
Last Edit: 3 years 7 months ago by cbanack.
The topic has been locked.

Re: Comic Vine Scraper 1.0.33 - 1.0.37 3 years 7 months ago #13258

  • 600WPMPO
  • 600WPMPO's Avatar
  • OFFLINE
  • Moderator
  • Posts: 3717
  • Thank you received: 480
  • Karma: 207
cbanack wrote:
Hmm... are these relatively new errors, or have they been happening for a while? The last CVS release was about 2 months ago, so if this problem only started happening in the last week or two, it's more likely a problem with ComicRack, or with the ComicVine website.
Honestly, I can't say since when these errors they are there. I haven't bulk scraped my comics for a long time now (probably at least a month). But, I'm sure I never did get them prior to 0.9.137/138.
cbanack wrote:
Do you know of any steps that might get this to happen reliably, so I can reproduce it? One idea might be that the problem only happens when you run some other script before you run CVS? Sometimes if a script shuts down improperly (or borrows some CVS code without renaming the modules) it can "pollute" the scripting environment for other scripts.
I do not get these errors regularly. But, mostly I've started CR and next thing I'm using CVS. I've not got these errors since I posted them yesterday, so I'll be on the lookout as to any specific book/step I see (if I get these errors again), and report them here.
Now Playing: The ComicRack Manual (Online)

See my new comics & gadgets on: Tumblr!
The topic has been locked.
Time to create page: 0.233 seconds

Who's Online

We have 180 guests and 2 members online
  • kenjio

PIM

You are not logged in.