Welcome, Guest
News and Announcements

TOPIC: Comic Vine Scraper

Comic Vine Scraper 11 months 10 hours ago #50039

  • cbanack
  • cbanack's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1371
  • Thank you received: 562
  • Karma: 188
pueblo wrote:
Hi folks,
Is it just me or is Comic Vine Scraper always ignoring volume and year information?
For example, I have a comic book:

Series: Adventure Comics
Year: 2010
Volume: 2009
Number: 519

Each time I run CV Scraper it shows additional windows “Choose a Comic Book Series” and first on the list is Adventure Comics from vol 1938.
The correct one (from vol 2009) is second on list. I always have to choose it manually.
Am I doing something wrong? How can I enforce checking volume or year? Maybe it’s CV Search API limitation?

The scraper 'remembers' which series (volumes) you've chosen in the past (it assumes you'll probably choose those ones again) so maybe you've accidentally chosen the 1938 volume a few times already, and now the scraper thinks it's one of your favorites...? Either way, if you keep choosing the correct volume one, it will sort itself out eventually.

There are also some advanced options that might help: github.com/cbanack/comic-vine-scraper/wiki/Advanced-Settings

In particular, IGNORE_BEFORE_YEAR might be of some use for you.
The administrator has disabled public write access.

Comic Vine Scraper 11 months 52 minutes ago #50049

  • pueblo
  • pueblo's Avatar
  • Offline
  • Junior Boarder
  • Posts: 30
  • Thank you received: 3
  • Karma: 0
Ok. I need to admit that I am not a fan of that kind of magic in programs but I really appreciate your effort.
Thank you for this tool anyway :)
The administrator has disabled public write access.

Comic Vine Scraper 10 months 1 week ago #50182

So, hello! Barging in here because after a couple of days of digging through all kinds of forums I can't fix this scraper problem.

Some brief specs: Windows 8.1 Update OS, ComicRack v. 0.9.178, ComicVineScraper script v. 1.096. There's no other particularly unusual setup. I do have an API key, and experimented with YACreader using its metadata scraper with no problems. I spent the last few days converting all cbr etc. files to cbz.

But I cannot for the life of me get the CVS to work.

When I select a comic and use the "automation" option to activate the script, I get the following error the first time:

Could not load file or assembly 'System.Web, Version=4.0.0.0, Culture=Neutral, PublicKeyToken=b03f5f7f11d50a3a' or one if its dependencies. The module was expected to contain an assembly manifest.

Subsequent attempts return the error: 'ScopeStorage' object has no attribute 'cvs_scrape'

The star icon for cvs is on the toolbar, but neither left clicking nor right-clicking and trying the "Configure" option work. Literally nothing happens, except I get the same error message.

I have no idea what's wrong and I'm not a programmer, so any help is appreciated explain any fixes "as you would to a child."
Last Edit: 10 months 1 week ago by PaleHorse42.
The administrator has disabled public write access.

Comic Vine Scraper 10 months 1 week ago #50183

  • cbanack
  • cbanack's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1371
  • Thank you received: 562
  • Karma: 188
Sounds like you're missing the .NET library on your system, or else some part of it has been damaged.

Instructions for installing or repairing .NET 4 can be found easily by googling. Here's one example:

kb.act.com/app/answers/detail/a_id/36078...version%3D4.0.0.0%2C
Last Edit: 10 months 1 week ago by cbanack.
The administrator has disabled public write access.
The following user(s) said Thank You: PaleHorse42

Comic Vine Scraper 10 months 1 week ago #50184

cbanack wrote:
Sounds like you're missing the .NET library on your system, or else some part of it has been damaged.

I had a perfectly fine NET library installed already... but I hadn't updated in a while. The big security update earlier this year Microsoft did had bombed my system, and I've done updates manually ever since. After a .NET update the scraper is working fine now! Thanks for pointing me in the right direction.
The administrator has disabled public write access.

Comic Vine Scraper 6 months 2 weeks ago #62420

  • Targg
  • Targg's Avatar
  • Offline
  • Senior Boarder
  • Posts: 55
  • Thank you received: 11
  • Karma: 5
As of yesterday afternoon, I am seeing some odd behaviors with the scraper. I had been scraping about 1000 comics a day this week, and yesterday the behavior changed.

It seems to now be giving results based on any of the words in the title. For example "X-Men vs Fantastic Four" would show results for "X-Men" "Fantastic" "Four" and "vs". The results list takes literally minutes to populate (it took seconds a few days ago), and the number of results shows in the thousands.

Nothing on my end has changed. I hadn't even closed ComicRack when the behavior changed.

Is there a way to limit the amount of search results? Anything with a common word or comic term (such as Spider-Man) takes forever, even when the specific title is very unique.

Thanks in advance for any help!
The administrator has disabled public write access.
The following user(s) said Thank You: snelson89, nianox, Bigby65

Comic Vine Scraper 6 months 2 weeks ago #62439

  • dreagan
  • dreagan's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 2
  • Karma: 1
yup, scraping takes a very long time now, especially on comics with common words in titles, I thought I was having internet issues when trying to scrape Detective Comics today.. :P

I have no idea how to fix this, but I think Comic Vine might have changed a couple of things on their end.
The administrator has disabled public write access.

Comic Vine Scraper 6 months 2 weeks ago #62440

  • cbanack
  • cbanack's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1371
  • Thank you received: 562
  • Karma: 188
I'll try to figure out what's going on (and hopefully find a way to fix the problem).

github.com/cbanack/comic-vine-scraper/issues/460
The administrator has disabled public write access.
The following user(s) said Thank You: alext41, Xelloss, nianox, LoLyfe, Bigby65, Vhorester

Comic Vine Scraper 6 months 2 weeks ago #62442

  • alext41
  • alext41's Avatar
  • Offline
  • Senior Boarder
  • Posts: 56
  • Thank you received: 20
  • Karma: 4
cbanack wrote:
I'll try to figure out what's going on (and hopefully find a way to fix the problem).

github.com/cbanack/comic-vine-scraper/issues/460

Great thank you for your effort.
The administrator has disabled public write access.
The following user(s) said Thank You: Vhorester

Comic Vine Scraper 6 months 1 week ago #62452

  • Xelloss
  • Xelloss's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 617
  • Thank you received: 189
  • Karma: 37
Xelloss wrote:
Till I have time to see how the new API works, I recommend using this:

File Attachment:

File Name: cvdb2.2.zip
File Size:9 KB


They probably switched back to the "show all results" (change "and" condition to "or" condition) as months ago, as I tried using my old patch and it is working again...

I suggest giving it a try to all having problems while cbanack fixs it :)

Note: I don't know if the problem is EXACTLY the same as the one I made this patch for that time, but it seems to work quite ok with my comics for now... If you want to try it just replace the file in the script folder and RESTART COMICRACK

edit: sorry, wrong file, now it is the correct one

Any feedback or problem, use this old topic: comicrack.cyolito.com/forum/13-scripts/4...r-patch-not-official (ignore the last posts where the "problem" was fixed months ago)
Last Edit: 6 months 1 week ago by Xelloss.
The administrator has disabled public write access.
The following user(s) said Thank You: Alan Scott, Targg, Vhorester, Freylis, ghoti
Time to create page: 0.544 seconds

Who's Online

We have 123 guests and one member online