Welcome, Guest
News and Announcements
  • Page:
  • 1
  • 2

TOPIC: ComicRack 0.9.119

ComicRack 0.9.119 7 years 6 months ago #6588

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 675
  • Karma: 181






New Features
* NEW: ComicRack can now run multiple shares with different settings at the same time
* NEW: Network clients can now export eComics locally if the server allows it


Changes
* CHANGE: Own Server is now displayed in the Server list (but can not be connected to)
* CHANGE: Fixed going through some proxies with the services
* CHANGE: InternetServerPort can now be set with command line (-isp) and ComicRack.ini
* CHANGE: PrivateServerPort can now be set with command line (-psp) and ComicRack.ini
* CHANGE: Removed Alt+Fx keyboard shortcuts
* CHANGE: Button in Export Dialog from "Add..." to "Save..."
* CHANGE: Open Remote Dialog now displays local shares and internet shares (including the share settings)
* CHANGE: Scraper now ignores multiple matches with the same link on a page (makes regexes easier)

Bugfixes
* BUGFIX: Fixed spelling "Updating"
* BUGFIX: Final fix for setting page types in RTL mode
* BUGFIX: Fixed possible progress bar drawing overflow for WebComic updates in Pending Tasks
* BUGFIX: "Filter" in Open Remote Dialog was not localizable
* BUGFIX: "eComics" in Page Menu was not localizable
* BUGFIX: Alt+F4 did not do default Windows action
* BUGFIX: Handling OpenGL error in blending animations
* BUGFIX: Pressing End on the Browser Tabs could crash ComicRack
* BUGFIX: Catch of possible clipboard errors

Tell me your opinion here :)

Donate and support this project!
Last Edit: 7 years 6 months ago by 600WPMPO.
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6590

  • Stonepaw
  • Stonepaw's Avatar
  • Offline
  • Moderator
  • Posts: 920
  • Thank you received: 267
  • Karma: 173
* CHANGE: Scraper now ignores multiple matches with the same link on a page (makes regexes easier)
That will make things much easier. Thanks!

So I assume it will just use the first match?

I don't really use the sharing features but this feature is very impressive!
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6591

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 675
  • Karma: 181
It means that if the same link is multiple times on the page, it will only take the first one. This way you get around the problem of duplicate pages.

If the matches are different, no change in the behavior (there could me multiple pages on one webpage...).
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6596

  • 600WPMPO
  • 600WPMPO's Avatar
  • Offline
  • Moderator
  • Posts: 3788
  • Thank you received: 557
  • Karma: 232
"Sharing on steroids" lol :-)
Now Playing: The ComicRack Manual (Online)

See my new comics & gadgets on: Tumblr!
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6606

  • Matt
  • Matt's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 16
  • Karma: 0
Hey cYo,

Still lovin' CR and by extension, your brain! However, one bug in CR still vexes me... when you click on anything listed in the browser windows it automatically takes that browser column back to the top. So if for example my left browser window is set to 'series' and I scroll down to the comic "Local" and click on it, the main windiw shows Local, but the series browser returns to "100 Bullets" :(

Is there any way to make it stay at "Local" (or whatever you click on)? It makes it easier to navigate your collection/select multiple series etc :)

(Note: up to 0.9.117 this bug didn't exist)


Cheers man!

Matt
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6607

  • forkicks
  • forkicks's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 869
  • Thank you received: 108
  • Karma: 37
Hi cYo

Good work on the network sharing on the last couple of releases, but i can't get the program to respect the OperationTimeout value. After 60 seconds exactly, it will always timeout/give me an error, no matter what i put on the OperationTimeout variable in the ini. I've changed client and server values to 600, and its always ignored. Anything else thats needed for it to used?

Thanks,
fK
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6609

  • Shinrai
  • Shinrai's Avatar
  • Offline
  • Platinum Boarder
  • With great power comes great W/T.
  • Posts: 885
  • Thank you received: 81
  • Karma: 33
I know you know better, fK, but in keeping with the first rule of technical support I feel obligated to verify that you did remember to uncomment the line, right? (With that out of the way, I haven't played with this feature so I can't really be any help.)
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6610

  • forkicks
  • forkicks's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 869
  • Thank you received: 108
  • Karma: 37
Shinrai wrote:
[...] you did remember to uncomment the line, right?

Yes, i did.

And on a seemingly unrelated note, the values commented on the .ini file are (should be?) the default values. You only need to uncomment any of those if you actually want to change it. The value for the Timeout is already 300 seconds in the .ini file, but thats not what im seeing, as i get the timeout after exactly 60 seconds (i timed this a few times to be sure).

fK
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6611

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 675
  • Karma: 181
the value is the OperationTimeout and not the ConnectionTimeout.
This is the timeout how long one an operation can take with the server.
The topic has been locked.

Re:ComicRack 0.9.119 7 years 6 months ago #6622

  • forkicks
  • forkicks's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 869
  • Thank you received: 108
  • Karma: 37
cYo wrote:
the value is the OperationTimeout and not the ConnectionTimeout.
This is the timeout how long one an operation can take with the server.

Yes, thats the one i tried. Just tried the other too (its not present in the ini the program creates by default), but still same result.

Is this working for someone?

fK
The topic has been locked.
  • Page:
  • 1
  • 2
Time to create page: 0.244 seconds

Who's Online

We have 246 guests and one member online