Welcome, Guest
Submit ComicRack for Android bugs to get them squashed

TOPIC: Can't initiate sync from device after factory reset

Can't initiate sync from device after factory reset 5 years 8 months ago #22339

Hi,
I just now preformed a factory reset on my Transformer tablet (TF101), reinstalled ComicRack, pointed it to my external storage comic folder (which already had files in it), and modified the settings to my previous choices before the reset. Everything seemed to be ok, until I noticed, I can't start a wireless sync from the device, only from the Windows app.
I mean I press the Wifi Sync button but nothing happens. I tried restarting the ComicRacks and the tablet itself but it didn't help.
It worked before the reset. I figured it's probably lost its paring or something (since I didn't backup apps before the reset and all cache and saved settings were lost) so I unpaired – paired, synced from the windows version, and tried again from the device. No go.
All ComicRacks are at their latest version.
Using pro version of ComicRack for android.
Help? :)
Last Edit: 5 years 8 months ago by acqnkgkyrqa.
The administrator has disabled public write access.

Re: Can't initiate sync from device after factory reset 5 years 8 months ago #22342

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 676
  • Karma: 182
Some firewall exceptions?
Different ip address?
It should work after re-pairing and restarting CRA and CRW as nothing has changed in the system before the upgrade.
The administrator has disabled public write access.

Re: Can't initiate sync from device after factory reset 5 years 8 months ago #22353

My router has DHCP, but the pc and device have reserved ip's.
No firewall is installed, and the Windows's version is off.
I should mantion that my smartphone also has CRA, and the sync works.

Quick update: I unpaired the device and than restarted both apps only than repaired them again. Still nothing, I dunno I had feeling it might work.


Any log I can export for you/me to see?
Last Edit: 5 years 8 months ago by acqnkgkyrqa.
The administrator has disabled public write access.

Re: Can't initiate sync from device after factory reset - More updates 5 years 8 months ago #22360

Ok, so I did some digging....
Fired up wireshark, and noticed CRA transmits a periodic multicast message to my network. That means network is fine.

Compared those packets to the ones my smartphone CRA sends, and they look similar (apart for the ID).
This is where I started messing around with the Config.xml on the PC version. I noticed that the ID written for the tablet device is different from the one stored in the xml.
I tried force changing the key attribute for the device's DeviceSyncSettings element to the one sniffed from the network and tried syncing, but it didn't work.
More over, CRW "found" another tablet device, on the pairing dialog and even added a new tab for it. So i had 2 device tabs for the same device.

Ok so it's matching problem now...
Once again I unpaired the device(s), and this time I cleared the CRA cache.
Before I did anything (including setting up the comic directory for CRA on the first startup) I tried paring them and this time I got the real ID from the packet.
So happy was I thinking I got it, I quickly changed CRA settings to point to my comic folder and tried resyncing - NO GO!
Went back to the paring dialog on CRW - Again a "new" device showed up with a different ID.

So here is what I concluded so far:
* for some reason, when I changed main comic folder on CRA, an ID changed occured - like there is some file or setting in the comic folder CRA's reading the ID from. Note that this folder was not deleted when I reset the device (it's on an external SD).

* The ID transmitted on the periodic packet is not the same one CRW directly queries from the device.

I am almost sure that if I just delete the entire comic folder on the device and clear the cache and try again, it will work. But I don't want to sync 12GB again if I can help it.

I hope I provided enough details, hope you can figure something out of it.

Regards.
The administrator has disabled public write access.

Re: Can't initiate sync from device after factory reset - More updates 5 years 8 months ago #22430

  • Tension113
  • Tension113's Avatar
  • Offline
  • Senior Boarder
  • Posts: 49
  • Thank you received: 2
  • Karma: 0
I had noticed this awhile back when I switched roms and then had to do it again last night when I changed roms again..

Put my existing comic folder from the sd in CRA..
Hit sync and nothing happens..
Repair device on CRW and it says my serial is (ex. abcde)

Made a new comic folder on the tablet
Repaired again on CRW and now the serial is (ex defgh)
Hit sync, it works, cancel sync..

Switch back to original comic folder on sd card in CRA
Hit sync, good to go..
The administrator has disabled public write access.

Re: Can't initiate sync from device after factory reset - resolved 5 years 7 months ago #22439

Well... got tired waiting for a response.
Just deleted my entire comic folder, created a new one, cleared CRA's cache and resyncd 12 GB over WIFI - BAH. After that the device initiated sync works once more - like I suspected it would in my last post.
The bug definitely is caused by using the pre-device reset comic folder.
CYO - See if you can catch fix it for future's sake.
The administrator has disabled public write access.
Time to create page: 0.178 seconds

Who's Online

We have 217 guests and 3 members online