Welcome, Guest
Section to post tutorials on how to manage and read your eComics

TOPIC: The Organizer 2015 (2nd edition)

The Organizer 2015 (2nd edition) 1 year 11 months ago #44352

  • Banedon
  • Banedon's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Thank you received: 3
  • Karma: 1
Nevermind. The custom field is there, it's just hidden unless you edit the comicrack.ini to show it. I think it's just that there's not rules set up for the specific books I'm running the tool on. Nothing to see here.
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 11 months ago #44404

  • Hexaphim
  • Hexaphim's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 12
  • Karma: 0
I can't find Datamanager.processed anywhere, and I've enabled custom fields. It doesn't seem like Data Manager is setting this value, or am I missing something?
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 11 months ago #44449

  • Arny
  • Arny's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
EDITED: Just updating this to say that you do need to edit the comicrack.ini as mentioned above to get the field to show. Make sure you restart.

That said, I'm still a little confused about this guide, so here are my initial questions:
  1. Do I setup Comicrack to watch my Comics directory or my 0-Day directory? Or both separately?
  2. Do all of my comics need to be in the root 0-Day directory? I already have a semi-organised folder structure in place and just copying that into the 0-Day directory doesn't seem to work with some of the latter Smart Lists (e.g. the Data Manager and Library Organizer lists)
  3. I'm assuming that I don't need to manually create all of the directories within Alphabetical, and that the Library Organizer script will take care of this as needed - is this correct?

Thanks, appreciate any clarification and help.
Last Edit: 1 year 11 months ago by Arny.
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 10 months ago #44605

Hello everyone, First of all thank you very much for the great job for everything, :) :) :)
I'm using software and these organizer 2015 (2nd edition) guide, It is really useful but I have a problem running Data manager on a series, and I have this log, in Data manager ''Your criteria matched no book. No data was touched by the Data Manager'' although I have scraped the series with comicvine and it's DC.
http://www.comicvine.com/oracle
I have the same problem with this one:
www.comicvine.com/hitman
Last Edit: 1 year 10 months ago by polotoniumx.
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 9 months ago #44773

  • MilkmanWes
  • MilkmanWes's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
  • Thank you received: 1
  • Karma: 0
Working with this and really enjoying it. For anyone daunted by the task of editing all of the file paths in the Organizer LibraryManager Profiles.lop file, it is xml/text. If you open it with a text editor (Sublime, Notepad, Notepad++, JEdit, etc) you can do a find and replace. Just open the file in the editor and open the search and replace dialog and search for E:\Comics and replace it with your drive letter and changes to your path. Save the file and then import it.
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 9 months ago #44778

  • MilkmanWes
  • MilkmanWes's Avatar
  • Offline
  • Junior Boarder
  • Posts: 26
  • Thank you received: 1
  • Karma: 0
Banedon wrote:
Nevermind. The custom field is there, it's just hidden unless you edit the comicrack.ini to show it. I think it's just that there's not rules set up for the specific books I'm running the tool on. Nothing to see here.


What is the edit you made?
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 9 months ago #44792

  • 2skoops
  • 2skoops's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 4
  • Karma: 0
You should see something like this in your .ini file:

; By default '.' custom values are hidden (used by plugins)
ShowCustomScriptValues = true

Make sure the 2nd line is set to "true", and is not commented out (make sure there is no semicolon ; at the start of the line). It should look exactly as above.
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 8 months ago #45207

In the Library Organizer smart list, is the ! next to
Custom Value DataManager.processed is
meant to be enabled or disabled. At the moment with the way it is I don't see any files in the smart list , yet all my comics are still in the 0 Day folder.
The administrator has disabled public write access.

The Organizer 2015 (2nd edition) 1 year 8 months ago #45223

  • 2skoops
  • 2skoops's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 4
  • Karma: 0
I had issues with this too ParalysedBeaver. What I ended up doing (and this is by no means the "right" or only way to approach it), was to make the "Library Organizer" list:
! Custom Value DataManager.processed is

This way, after being processed in the "DataManager", it shows up in the "Library Organizer" list.

However, the other problem is that running a comic through the DataManager only adds the DataManager.processed value if one of the rules was matched and DataManager actually did something (ex. set "Batman" series group). So for a large number of comics, nothing ever gets set.

My approach to this was to add a new rule to DM which guarantees every comic gets tagged. What I did was add a rule called "Catch All" to the bottom of the "Cleanup" section:

Rules:
SeriesGroup Is ""

Actions:
Tags Add "DMProc"
Tags Remove "DMProc"

You could make the rule more broad if you wanted (ex. Series Not ""), and the Action could be any tag you want. The idea is just to set and remove something so that DataManager timestamps the DataManager.processed value.

Anyway, like I said, this isn't the only way to do things, but it's what I ended up doing and it works for me.
The administrator has disabled public write access.
The following user(s) said Thank You: Haired

The Organizer 2015 (2nd edition) 1 year 8 months ago #45282

  • Uplinkpro
  • Uplinkpro's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
Hey guys LOVE this guide following it to the letter but i have run into one problem that's probably easy to fix but i haven't figured it out yet. The problem stems from having a Series that starts with a number but is a "Main Series". If its not marked as a main series it will go to the # folder like normal. However if its Marked, it makes a 1 folder in the Main comic folder underneath the # (Im using 10th muse as a test im sure thats why its 1) How would i go about fixing this issue do i need a new rule or am i missing something? This also happens with one shots and Limited series it seems.
Last Edit: 1 year 8 months ago by Uplinkpro. Reason: adding more info
The administrator has disabled public write access.
Time to create page: 0.214 seconds

Who's Online

We have 246 guests and no members online