Welcome, Guest
General discussion about ComicRack

TOPIC: Last ComicRack version (0.9.177) not compatible with XP

Last ComicRack version (0.9.177) not compatible with XP 1 year 11 months ago #44279

  • hetchel
  • hetchel's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 1
  • Karma: 0
Due to upping .NET version to 4.5, which is not available for XP.
if cYo wants to drop support for XP, I think it is a pity, but it is his choice. I understand that it is discontinued and all.
But I'd hardly name "maintenance release" to one that breaks compatibility with more than 5% of the users.
There is also no warning in the changelog, or in the download page, or in the installer (when tries to install .NET 4.5 and fails... the installer should ALWAYS warn when it tries to install .NET and fails...) or in the readme.
So I request cYo to "downgrade" to 4.0 (if using 4.5 is not mandatory for some of the features he included/want to include) or at least to include the proper warnings in the places mentioned about Windows XP not being supported anymore (pointing to the last XP-compatible version will be a bonus, specially in the downloads page: it is not easy to download previous versions).
Greetings.
Last Edit: 1 year 11 months ago by hetchel.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 11 months ago #44280

  • hetchel
  • hetchel's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 1
  • Karma: 0
Here:
http://www.fileloco.com/windows/photos_and_images/comicrack
Is where I found the last XP-compatible version (0.9.176).
I couldn't find anywhere in this site (an unfortunate time to change the Web, I believe)
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 11 months ago #44281

  • Innuendo
  • Innuendo's Avatar
  • Offline
  • Expert Boarder
  • Posts: 91
  • Thank you received: 17
  • Karma: 7
I don't think dropping support for XP is unreasonable. Windows XP was released in 2001 which was 14 years ago. Your request is akin to if when Windows XP was released someone complaining that software no longer supports Windows 3.1 (which was released only 9 years prior).
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 11 months ago #44283

  • krandor
  • krandor's Avatar
  • Offline
  • Gold Boarder
  • Posts: 204
  • Thank you received: 21
  • Karma: 4
Innuendo wrote:
I don't think dropping support for XP is unreasonable. Windows XP was released in 2001 which was 14 years ago. Your request is akin to if when Windows XP was released someone complaining that software no longer supports Windows 3.1 (which was released only 9 years prior).

I agree it is not unreasonable. However, I do agree with the OP that it would have been a good thing to mention in the upgrade notes.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 10 months ago #44378

  • Innuendo
  • Innuendo's Avatar
  • Offline
  • Expert Boarder
  • Posts: 91
  • Thank you received: 17
  • Karma: 7
[quote="krandor" post=44283I agree it is not unreasonable. However, I do agree with the OP that it would have been a good thing to mention in the upgrade notes.[/quote]

Sorry it took me so long to get back to this discussion, but I wanted to say that despite my stance on the support of XP that I do agree with you 100%. A change this monumental should have made it to the changelog. An announcement on the front page would have been a nice touch as well.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 10 months ago #44424

  • cYo
  • cYo's Avatar
  • Offline
  • Moderator
  • Posts: 3476
  • Thank you received: 676
  • Karma: 181
Sorry, my fault.
Did not really check the requirements for .NET 4.5

But this day had to come anyway. Running XP on a networked PC is inviting disaster.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 10 months ago #44463

  • hetchel
  • hetchel's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 1
  • Karma: 0
cYo wrote:
Sorry, my fault.
Did not really check the requirements for .NET 4.5

But this day had to come anyway. Running XP on a networked PC is inviting disaster.

Thanks for your response. I understand your opinion about XP, but the reality is that a non-trivial amount of people is still using it for a variety of reasons (some may seem more "reasonable" than others)
Will you consider returning back to .NET 4.0 in future versions, or do you need .NET 4.5 for current/work in progress features?
In the meantime/at the very least, it would be good if you added the last XP-compatible version to the downloads page.
Greetings.
Last Edit: 1 year 10 months ago by hetchel.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 10 months ago #44471

  • oraclexview
  • oraclexview's Avatar
  • Offline
  • Moderator
  • aka SoundWave
  • Posts: 906
  • Thank you received: 182
  • Karma: 37
hetchel wrote:
Thanks for your response. I understand your opinion about XP, but the reality is that a non-trivial amount of people is still using it for a variety of reasons (some may seem more "reasonable" than others)
Will you consider returning back to .NET 4.0 in future versions, or do you need .NET 4.5 for current/work in progress features?
In the meantime/at the very least, it would be good if you added the last XP-compatible version to the downloads page.
Greetings.
Sorry my friend. I wouldn't count on a retreat back in time to assist the 5% (if even that many) of users still living in the dark ages. Being released over 14 years ago is a long time ago. In the computer world that's almost like the equivalent of a century. lol. Though, I'm curious to know why are you still using XP? I think that you would LOVE Win 7 once you switch over. I have honestly only come across less than a handful of apps in the last few years that haven't been updated to work on Win 7 or better.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 10 months ago #44472

  • Fuzzyluzzi
  • Fuzzyluzzi's Avatar
  • Offline
  • Gold Boarder
  • Posts: 301
  • Thank you received: 44
  • Karma: 10
Can't upgrade XP to 7. 32v64. Using a computer at work that the company won't upgrade. For personal use, browsing the web & stuff that isn't on company server.
Also too damn lazy to upgrade my home PC. It only runs CRW and Plex.
The administrator has disabled public write access.

Last ComicRack version (0.9.177) not compatible with XP 1 year 10 months ago #44473

  • oraclexview
  • oraclexview's Avatar
  • Offline
  • Moderator
  • aka SoundWave
  • Posts: 906
  • Thank you received: 182
  • Karma: 37
Fuzzyluzzi wrote:
Can't upgrade XP to 7. 32v64. Using a computer at work that the company won't upgrade. For personal use, browsing the web & stuff that isn't on company server.
Also too damn lazy to upgrade my home PC. It only runs CRW and Plex.
Win 7 does come in 32bit flavor, though I wouldn't upgrade a XP to WIn 7. I'd personally do a fresh install of Win 7, or if you want a newer computer you can always go with hardware that's outdated by say 3 to 4 years that way you can get a new Win 7 computer for cheap. Yet hey, I'm lazy too, so I mos def don't do all the things I should to keep my Win computer running smooth and clean and properly backed up like I should. lol. Also, I totally understand the work situation. My manager just refuses to pay for new software licenses that we would need to upgrade the one last app we use that prevents us from getting ride of our old ass XP machines. It's so irritating.
Last Edit: 1 year 10 months ago by oraclexview.
The administrator has disabled public write access.
Time to create page: 0.220 seconds

Who's Online

We have 195 guests and 2 members online