Welcome, Guest
Try to get help from other ComicRack users

TOPIC: Database not saving updates after restart

Database not saving updates after restart 4 days 19 hours ago #47563

  • fieldhouse
  • fieldhouse's Avatar
  • Online
  • Expert Boarder
  • Posts: 87
  • Thank you received: 9
  • Karma: 1
Really not sure what's going on with this one. I'm using MySQL and transferred my database off of an older, underpowered machine to a new, bigger, better box. Everything looks fine at first glance... ComicRack loads much quicker, I can scan for new files and use ComicVine Scraper to update their data. Searches are much snappier and all of the updates I made show up. until...

Everything behaves completely normal until I exit out of ComicRack and start it back up. Then, I'm transported back in time to the beginning of Groundhog Day - just after the database restore. Nothing has been saved / updated in MySQL.

I thought it might have something to do with it being a newer version of MySQL so I ran mysql_upgrade but it still acts like the databae is read-only. I also tried installing MySQL on a third system but had the same read-only-ish behavior.

Just to rule out any issues with the client, I fired up a new install of ComicRack on another PC. I see the same behavior: library book total reverts to the previous value after a restart of the app. No updated files. Welcome to Groundhog Day.

Anyone have suggestions? I think the next thing I'll try is a brand-new database on the new machine but I get the feeling that it'll work and I won't be any closer to having an updatable database with all of my existing info. :blink:
The administrator has disabled public write access.

Database not saving updates after restart 2 days 13 hours ago #47578

  • jkthemac
  • jkthemac's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 706
  • Thank you received: 234
  • Karma: 52
Have you tried checking the database directly while ComicRack is open to see if the data is being altered?

I wonder if the issue is with the user permissions?
Last Edit: 2 days 13 hours ago by jkthemac.
The administrator has disabled public write access.
Time to create page: 0.146 seconds

Who's Online

We have 274 guests and 3 members online